Sign in with
Sign up | Sign in
Your question
Solved

PC starts and shuts down immediately (New PSU and GPU)

Tags:
  • EVGA
  • Components
  • gtx 770
  • Corsair
  • fail boot
  • Shutdown
  • GPUs
Last response: in Components
August 8, 2013 10:58:58 AM

Hi. I just received a new PSU and GPU. Corsair GS800 2013 Edition and EVGA Gtx 770 Acx Superclocked respectively.
I replaced my old parts with the new ones and found out that the PC starts up (i.e. all fans spin up) and then after 2-3 seconds it shuts down. I tried putting in the old PSU and keeping the new GPU - same issue. I also tried new PSU and old GPU - same issue. After that I tried putting in old PSU and old GPU back in and I'm getting the same issue again. This probably means that the new GPU and PSU are working as intended and I messed something up inside the PC. Now this is my question - what could've gone wrong? I was being gentle with the motherboard and I can't think of any physical damage I've done.
I checked if the power button and reset cables are in the right place - they are. I checked the pins on the motherboard power socket - all good. I haven't even touched the CPU so there is no point checking it. I have checked the RAM too, all seems to be working fine. I'm completely lost. Any ideas would be appreciated.

PC specs (including old gpu and psu):
Gigabyte GA-Z77-D3H
Intel Core i5-2500K Sandy Bridge 3.3GHz
Evga Gtx 560Ti 448 Classified
Corsair 16GB DDR3 1600Mhz Vengeance Memory
Asus Xonar DG sound card
OCZ 120GB Agility 3 SSD
WD Caviar Black 1TB
Unknown brand 800W PSU (it came with my PC when I bought it 2 years ago and worked fine since)

More about : starts shuts immediately psu gpu

August 8, 2013 11:14:15 AM

I would suggest you check that the ram is properly seated in the slot also take the CPU out and reinsert it and check that all the Molex connectors from the psu to your mobo is attached tightly
    m
    0
    l

    Best solution

    August 8, 2013 11:24:44 AM

    Wild stab in the dark...

    Check the I/O shield, make sure there's nothing shorting out any of the sockets.
    I had this once, one of the tiny springy pins on the I/O shield had been squeezed
    sideways and was poking into an audio socket. It made the system shut down
    shortly after being turned on. Likewise, check to be sure there are no shorts
    anywhere else. Also, make sure on the molex connections that none of them
    have ended up with one of the socket receptacles being pushed out because of
    a poorly aligned plug pin.

    With the GPU/RAM removed, check to see if there are any foreign bodies in
    the various sockets. I use a can of inert compressed air to ensure sockets
    are clean before installing things.

    Pair down the system a bit, reduce to the minimum required. Fit just one DIMM,
    unplug the WD 1TB, sound card and any DVDRW/etc.

    If it still isn't playing ball, pull all the bits out of the case and set it all up in the
    open on some suitable surface, like a phone book. I do this for testing before
    moving PC builds into cases, eg.:

    http://www.sgidepot.co.uk/misc/pcbenchmarking2.jpg

    Ian.

      Share
      Related resources
      August 8, 2013 11:36:54 AM

      I feel really really dumb now. Luckily everything is fine. I managed to sort it out. It turns out that the 4pin connector that goes into the motherboard was slightly loose (even though I made sure it's firmly attached). I went through every connection in the motherboard and then realised that the connection is a tiny bit loose.

      Thanks for your replies anyway! Moral of the story - when shit goes down don't panic and slowly check everything. The fix is usually incredibly simple!
        m
        0
        l
        August 8, 2013 11:54:13 AM


        Glad to hear you got it fixed! 8)

        That is one downside of the old molex connector, after some usage it can lose the
        original stiffness when connected. I have some SCA adapters which suffer from this.

        Ian.


          m
          0
          l
          !
          web counter